Actually, that is not quite right.  From the FAQ:


This feature currently only exists in the trunk version of the Open MPI library.” 


You need to download and use the trunk version for this to work.




From: [] On Behalf Of Ralph Castain
Sent: Thursday, October 27, 2011 11:43 AM
To: Open MPI Users
Subject: Re: [OMPI users] configure with cuda



I'm pretty sure cuda support was never moved to the 1.4 series. You will, however, find it in the 1.5 series. I suggest you get the latest tarball from there.



On Oct 27, 2011, at 12:38 PM, Peter Wells wrote:


I am attempting to configure OpenMPI 1.4.3 with cuda support on a Redhat 5 box. When I try to run configure with the following command:


 ./configure --prefix=/opt/crc/sandbox/pwells2/openmpi/1.4.3/intel-12.0-cuda/ FC=ifort F77=ifort CXX=icpc CC=icc --with-sge --disable-dlopen --enable-static --enable-shared --disable-openib-connectx-xrc --disable-openib-rdmacm --without-openib --with-cuda=/opt/crc/cuda/4.0/cuda --with-cuda-libdir=/opt/crc/cuda/4.0/cuda/lib64


I receive the warning that '--with-cuda' and '--with-cuda-libdir' are unrecognized options. According to the FAQ these options are supported in this version of OpenMPI. I attempted the same thing with v.1.4.4 downloaded directly from with similar results. Attached are the results of configure and make on v.1.4.3. Any help would be greatly appreciated.


Peter Wells
HPC Intern
Center for Research Computing
University of Notre Dame

users mailing list


This email message is for the sole use of the intended recipient(s) and may contain confidential information.  Any unauthorized review, use, disclosure or distribution is prohibited.  If you are not the intended recipient, please contact the sender by reply email and destroy all copies of the original message.