Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] OpenMPI 1.6.3 and Memory Issues
From: Joseph Farran (jfarran_at_[hidden])
Date: 2012-11-29 19:54:22

Hi again.

I am using /etc/modprobe.d/mofed.conf, otherwise I get:

WARNING: Deprecated config file /etc/modprobe.conf, all config files belong into /etc/modprobe.d/

But I am still getting the memory errors after making the changes and rebooting:

$ cat /etc/modprobe.d/mofed.conf
options mlx4_core log_num_mtt=24
options mlx4_core log_mtts_per_seg=1

$ mpirun hello
WARNING: It appears that your OpenFabrics subsystem is configured to only
allow registering part of your physical memory. This can cause MPI jobs to
run with erratic performance, hang, and/or crash.

On 11/29/2012 04:39 PM, Yevgeny Kliteynik wrote:
> You can also set these parameters in /etc/modprobe.conf:
> options mlx4_core log_num_mtt=24 log_mtts_per_seg=1
> -- YK