Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] mpi test program "ring" failed: blocked at MPI_Send
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2012-09-26 02:10:55

Richard and I iterated more off list:

Short version: the correct "exclude" form for Richard is:

    --mca btl_tcp_if_exclude virbr0,lo

More detail: I totally forgot that while OMPI excludes loopback devices by default, if you override the value of btl_tcp_if_exclude, if you still want loopback to be skipped (and you most likely do), you need to include loopback in your new value. Hence, just excluding virbr0 isn't sufficient (because that then *includes* the loopback devices). Instead, you need to exclude *both* virbr0 and lo. Then all works as expected.

Sorry for the runaround! I'm going to blame it on jet lag. :-)

On Sep 26, 2012, at 3:06 AM, Richard wrote:

> Jeff,
> It was a typo in my last post, I did use "--mca btl_tcp_if_exclude virbr0" and it did not work.
> At 2012-09-25 21:10:24,"Jeff Squyres" <jsquyres_at_[hidden]> wrote:
> >On Sep 25, 2012, at 2:56 PM, Richard wrote:
> >
> >> thanks a lot !
> >> using "--mca btl_if_exclude virbr0" does not work, but you have pointed out the
> >
> >Ya, sorry -- see my second mail, it should be "btl_tcp_if_exclude".
> >
> >> problem, so i fixed it using "--mca btl_tcp_if_include bond0" because I know this is the high speed network interface I should use on each node.
> >
> >Glad it works for you!
> >
> >If you're not using those interfaces (they might be related to Xen, or something like that?), you might want to disable them.
> >
> >--
> >Jeff Squyres
> >jsquyres_at_[hidden]
> >For corporate legal information go to:
> >
> >
> >_______________________________________________
> >users mailing list
> >users_at_[hidden]
> >
> _______________________________________________
> users mailing list
> users_at_[hidden]

Jeff Squyres
For corporate legal information go to: