Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] MPI doesn't recognize multiple cores available on multicore machines
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2012-04-25 12:29:32

I just re-read the thread.

I think there's a little confusion between the terms "processor" and "MPI process" here.

You said "As a pre-processing step, each processor must figure out which other processors it must communicate with by virtue of sharing neighboring grid points."

Did you mean "MPI process" instead of "processor"?

Secondly, if you're just running on a single machine with no scheduler and no hostile, you should be able to:

  mpirun -np <whatever_you_want> your_program_name

When you get the "There are not enough slots available in the system..." message, that usually means that *something* is telling Open MPI a maximum number of processes that can be run, and your -np value is greater than that. This is *usually* a scheduler, but can also be a hostile and/or an environment variable or file-based MCA parameter.

On Apr 25, 2012, at 12:24 PM, Kyle Boe wrote:

> > Any chance you could upgrade to Open MPI 1.5.5? It has a better version of the processor affinity stuff than the 1.4 series.
> Did this and recompiled everything that depended on OMPI. No difference whatsoever. It still tells me, if I specify -np 2 for example, that "There are not enough slots available in the system to satisfy the 2 slots
> that were requested by the application."
> >My bad. I did not read the bottom part of the email. Not sure If this would help, but can u try, --mca btl sm,self ?
> This also does not change anything...
> Really confused what is going on here!
> Kyle
> _______________________________________________
> users mailing list
> users_at_[hidden]

Jeff Squyres
For corporate legal information go to: