Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] PathScale problems persist
From: Rafael Arco Arredondo (rafaarco_at_[hidden])
Date: 2010-09-23 03:56:08

I am using GCC 4.x:

$ pathCC -v
PathScale(TM) Compiler Suite: Version 3.2
Built on: 2008-06-16 16:41:38 -0700
Thread model: posix
GNU gcc version 4.2.0 (PathScale 3.2 driver)

$ pathCC -show-defaults
Optimization level and compilation target:
   -O2 -mcpu=opteron -m64 -msse -msse2 -mno-sse3 -mno-3dnow -mno-sse4a

And I also tried with mpiCC -gnu4 to be totally sure. It's rather weird
that I get this error and Ake does not...

I configured Open MPI with PathScale with the following line, by the

./configure --with-openib=/usr --with-openib-libdir=/usr/lib64
--with-sge --enable-static CC=pathcc CXX=pathCC F77=pathf90 F90=pathf90

And with GCC:

./configure --with-openib=/usr --with-openib-libdir=/usr/lib64
--with-sge --enable-static

It's not an Infiniband or SGE issue. I also tried with all processes
running on the same node and without SGE.

Best regards,


On Wed, 2010-09-22 at 14:54 +0200, Ake Sandgren wrote:
> On Wed, 2010-09-22 at 14:16 +0200, Ake Sandgren wrote:
> > On Wed, 2010-09-22 at 07:42 -0400, Jeff Squyres wrote:
> > > This is a problem with the Pathscale compiler and old versions of
> GCC. See:
> > >
> > >
> > >
> > > I note that you said you're already using GCC 4.x, but it's not
> clear from your text whether pathscale is using that compiler or a
> different GCC on the back-end. If you can confirm that pathscale *is*
> using GCC 4.x on the back-end, then this is worth reporting to the
> pathscale support people.
> >
> > I have no problem running the code below compiled with openmpi 1.4.2
> and
> > pathscale 3.2.
> And i should of course have specified that this is with a GCC4.x
> backend.

Rafael Arco Arredondo
Centro de Servicios de Informática y Redes de Comunicaciones
Campus de Fuentenueva - Edificio Mecenas
Universidad de Granada
E-18071 Granada Spain
Tel: +34 958 241010   Ext:31114   E-mail: rafaarco_at_[hidden]