Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] INSTALL bug in 64-bit build of OpenMPI Release build on Windows - has workaround
From: Damien Hocking (damien_at_[hidden])
Date: 2010-02-04 17:52:32


I started again from the beginning to sort out exactly what was going
on. Here's what I found.

If I use the CMake GUI, and set CMAKE_BUILD_TYPE to Release,
re-configure and then generate, and then do the following build command:

"devenv OpenMPI.sln /build"

I get the following:

1>------ Build started: Project: libopen-pal, Configuration: Debug x64

etc. It still builds debug versions, and pdbs. The install project
doesn't try to install the pdbs though.

If I do a "devenv OpenMPI.sln /build release", I get a proper release
build, no pdbs and the install project works.

If I use the CMake GUI, and leave CMAKE_BUILD_TYPE at Debug, and do
"devenv OpenMPI.sln /build release", I get a release build, but the
install fails because it goes looking for pdbs that aren't there.

So, in order to get a Release build that installs using the CMake GUI,
you need to have CMAKE_BUILD_TYPE set to Release *and* do a

"devenv OpenMPI.sln /build release" at the command line, followed by
"devenv OpenMPI.sln /build release /project INSTALL".

To get a Release build from the command-line without using the CMake
GUI, you need to have SET(CMAKE_BUILD_TYPE Release) in the top-level
CMakeFiles.txt, and then

"devenv OpenMPI.sln /build release" at the command-line, followed by
"devenv OpenMPI.sln /build release /project INSTALL"

As Shiquing said in another post, you need to do completely independent
setups for 32 and 64-bit builds. I set mine up with build32 and build64
directories, and install32 and install64 directories to keep everything
separate.

HTH,

Damien

On 04/02/2010 7:34 AM, Marcus G. Daniels wrote:
>> Hmmm. I did try setting release and I think I still got pdbs. I'll try
>> again from a totally clean source tree and post back.
>
> Another datapoint:
>
> I tried Cmake's Generate after setting CMAKE_BUILD_TYPE and building.
> I have the same sort of build problems with setting x64 in the VS 2008
> configuration manager.
>
> Marcus