Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] OpenMPI 1.3.1 + BLCR build problem
From: Josh Hursey (jjhursey_at_[hidden])
Date: 2009-03-31 15:48:05

I think that the missing configure option might be the problem as
well. The BLCR configure logic checks to see if you have enabled
checkpoint/restart in Open MPI. If you haven't then it fails out of
configure (probably should print a better error message - I'll put
that on my todo list).

The configure flag that you are looking for is:

So try the following and let me know if that fixes the problem for you:
   ./configure --with-ft=cr --with-blcr=/opt/blcr --with-blcr-libdir=/
opt/blcr/lib --prefix=/opt/openmpi

Some of the configure options and runtime options are discussed in the
Checkpoint/Restart in Open MPI User's Guide which you can find linked
at the bottom of the following wiki page:

You may also want to consider using the thread options too for
improved C/R response:
   --enable-mpi-threads --enable-ft-thread


On Mar 31, 2009, at 2:49 PM, Dave Love wrote:

> M C <m_c_001_at_[hidden]> writes:
>> --- MCA component crs:blcr (m4 configuration macro)
>> checking for MCA component crs:blcr compile mode... dso
>> checking --with-blcr value... sanity check ok (/opt/blcr)
>> checking --with-blcr-libdir value... sanity check ok (/opt/blcr/lib)
>> configure: WARNING: BLCR support requested but not found. Perhaps
>> you need to specify the location of the BLCR libraries.
>> configure: error: Aborting.
>> This is strange, as both /opt/blcr and /opt/blcr/lib are sensibly
>> populated:
> I ran into this recently. You need an extra flag which I forget, but
> ./configure --help will show it can take `LAM' as an argument. It
> seems
> pretty obscure and probably deserves a report I haven't had time to
> make.
> _______________________________________________
> users mailing list
> users_at_[hidden]