Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: [OMPI users] Fail to install openmpi 1.2.5 on bladecenter with OFED 1.3
From: Mohd Radzi Nurul Azri (nurulazri_at_[hidden])
Date: 2008-08-12 13:32:39


I've been trying to install openmpi 1.2.5 on my cluster system running RHEL
4 (x64) with OFED 1.3. I need openmpi 1.2.5 (32 bit) and OFED seems to only
install 64 bit version. I tried to build OFED with 32 bit support but it
failed so I figure it's best to just compile 32 bit openmpi. I followed the
FAQ and few user experience on the web.

I ran this command:
./configure --prefix=/usr/mpi/gcc/32bit --with-openib=/usr CFLAGS=-m32

and after few scrolling lines, it stops here:
--- MCA component btl:openib (m4 configuration macro)
checking for MCA component btl:openib compile mode... dso
looking for header without includes
checking infiniband/verbs.h usability... yes
checking infiniband/verbs.h presence... yes
checking for infiniband/verbs.h... yes
looking for library without search path
checking for ibv_open_device in -libverbs... no
looking for library in lib
checking for ibv_open_device in -libverbs... no
looking for library in lib64
checking for ibv_open_device in -libverbs... no
checking for ibv_create_srq... no
checking for ibv_get_device_list... no
checking for ibv_resize_cq... no
configure: WARNING: OpenFabrics support requested (via --with-openib) but
not fo und.
configure: WARNING: If you are using libibverbs v1.0 (i.e., OFED v1.0 or
v1.1), you *MUST* have both the libsysfs headers and libraries installed.
Later versio ns of libibverbs do not require libsysfs.
configure: error: Aborting.

What went wrong? From the error it says early OFED version which is not the
one I'm using (running OFED 1.3 now).

Any advice is greatly appreciated.

Thank you.