Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

Subject: Re: [OMPI users] mpi.h macro naming
From: Brian W. Barrett (brbarret_at_[hidden])
Date: 2008-02-22 12:40:40

A second attempt, this time with less suck :).


On Fri, 22 Feb 2008, Brian W. Barrett wrote:

> Oops.. forgot to test the C++ bindings, which of course broke. Let me
> try again and I'll send a better patch.
> brian
> On Fri, 22 Feb 2008, Brian W. Barrett wrote:
>> On Thu, 21 Feb 2008, Jeff Squyres wrote:
>>> While I agree that having AC actually define them to a value is a Good
>>> Thing (better than just defining it to be empty), I do see the pickle
>>> that it has put us in. :-\ I don't see an obvious solution.
>> I do :). Try the attached patch. It sneaks in at the last minute and
>> defines (for example) both SIZEOF_BOOL and OMPI_SIZEOF_BOOL. mpi.h only has
>> the define for OMPI_SIZEOF_BOOL. opal_config.h has both, but a note saying
>> not to use the OMPI_ version. Seems to work.
>> Brian
> _______________________________________________
> users mailing list
> users_at_[hidden]