Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Rob (spamrefuse_at_[hidden])
Date: 2007-05-05 22:53:10


I have been trying to get MPI working on two old AlphaServers in my lab:
es40 and es45 models.
I prefer using OpenMPI, but as far as I understand, OpenMPI does not
support AlphaServers anymore.

Just for the record here, I'd like to report that eventually I got MPI working
on my two AlphaServers using MPICH1
as follows:

setenv LD_LIBRARY_PATH /opt/gcc/lib
setenv PATH /opt/gcc/bin:${PATH}
setenv CXX /opt/gcc/bin/g++
setenv CCFLAGS -mfp-trap-mode=su
setenv CC /opt/gcc/bin/gcc
setenv CFLAGS -mfp-trap-mode=su
setenv FC /opt/gcc/bin/gfortran
setenv FFLAGS -mfp-trap-mode=su
setenv F90 /opt/gcc/bin/gfortran
setenv F90FLAGS -mfp-trap-mode=su
setenv F77_GETARGDECL " "
setenv RSHCOMMAND ssh
./configure --prefix=/opt/mpich --with-arch=LINUX_ALPHA

The reference to /opt/gcc is my own compilation of current GCC gcc/g++ and
fortran compilers; the latter can handle F90 and F95 code, hence I'm able to
generate decent mpif77 and mpif90 compilers.
The "-mfp-trap-mode=su" flag is needed with GCC on the AlphaServers,
to prevent runtime SIGSEGV aborts.
Without the "F77_GETARGDECL", the MPI fortran compiler will not build.


Ahhh...imagining that irresistible "new car" smell?
 Check outnew cars at Yahoo! Autos.