Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Peter Beerli (beerli_at_[hidden])
Date: 2006-08-17 11:09:08

Today I ran into the same problem as Warner Yuen (see thread below),

openmpi does not compile with icc and fails with an error where
libtool ask for --tag. The error is macosx specific.

It occurs in the compile for xgrid



the Makefile fails; xgrid uses some objective-C stuff that needs to
be compiled with gcc [I guess]

after adjusting the


xgrid>grep -n "\-\-tag=OBJC"
216:LTOBJCCOMPILE = $(LIBTOOL) --mode=compile $(OBJC) $(DEFS) \
220:OBJCLINK = $(LIBTOOL) --mode=link $(OBJCLD) $(AM_OBJCFLAGS) \

xgrid>grep -n "\-\-tag=OBJC"
216:LTOBJCCOMPILE = $(LIBTOOL) --tag=OBJC --mode=compile $(OBJC) $
(DEFS) \
220:OBJCLINK = $(LIBTOOL) --tag=OBJC --mode=link $(OBJCLD) $

the change elicits a warning that OBJC is not a known tag, but it
keeps going and compiles fine.
I do not use the xgrid portion so I do not now whether this is
clobbered or not. Standard runs using orterun
work fine.


Brian Barrett wrote in July:
> On Jul 14, 2006, at 10:35 AM, Warner Yuen wrote:
> > I'm having trouble compiling Open MPI with Mac OS X v10.4.6 with
> > the Intel C compiler. Here are some details:
> >
> > 1) I upgraded to the latest versions of Xcode including GCC 4.0.1
> > build 5341.
> > 2) I installed the latest Intel update (9.1.027) as well.
> > 3) Open MPI compiles fine with using GCC and IFORT.
> > 4) Open MPI fails with ICC and IFORT
> > 5) MPICH- compiles fine with ICC and IFORT (I just had to
> > find out if my compiler worked...sorry!)
> > 6) My Open MPI confguration was using: ./configure --with-rsh=/usr/
> > bin/ssh --prefix=/usr/local/ompi11icc
> > 7) Should I have included my config.log?
> It looks like there are some problems with GNU libtool's support for
> the Intel compiler on OS X. I can't tell if it's a problem with the
> Intel compiler or libtool. A quick fix is to build Open MPI with
> static libraries rather than shared libraries. You can do this by
> adding:
> --disable-shared --enable-static
> to the configure line for Open MPI (if you're building in the same
> directory where you've already run configure, you want to run make
> clean before building again).
> I unfortunately don't have access to a Intel Mac machines with the
> Intel compilers installed, so I can't verify this issue. I believe
> one of the other developers does have such a configuration, so I'll
> ask him when he's available (might be a week or two -- I believe he's
> on vacation). This issue seems to be unique to your exact
> configuration -- it doesn't happen with GCC on the Intel Mac nor on
> Linux with the Intel compilers.
> Brian
> --
> Brian Barrett
> Open MPI developer