Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2006-08-06 08:51:28

Open MPI was not designed to handle all of those flags. We do have an
"--enable-debug" mode that adds a bunch of compiler flags, but not all of
the ones that you specified.

In particular, however, -pedantic works for me (it's automatically added
with --enable-debug). Running configure on my macbook with 10.4.7 with
--enable-debug shows:

checking for long long... yes


checking size of long long... 8


checking alignment of long long... 4

If you need more information, please send the data listed here:

On 8/5/06 6:35 PM, "Manav Bhatia" <manav_at_[hidden]> wrote:

> Hi,
> I am using OpenMPI 1.1 on Mac OS 10.4.7 with intel processors. I
> compiled and installed using the following options:
> /configure --prefix=/usr/local/openmpi --disable-mpi-f77 --disable-
> mpi-f90
> Everything compiles and runs fine in optimized mode using mpic++,
> however, I get the following compilation error message when compiling
> in debug mode
> /usr/local/openmpi/include/mpi.h:147: error: ISO C++ does not support
> 'long long'
> I am using the following compiler options in optimized mode
> -DNDEBUG -fno-common -O2 -felide-constructors -funroll-loops -fstrict-
> aliasing -Wdisabled-optimization
> and the following in debug mode
> -DDEBUG -fno-common -O0 -felide-constructors -g -ansi -pedantic -W -
> Wall -Wunused -Wpointer-arith -Wimplicit -Wformat -Wparentheses -
> Kindly help me understand what is happening here, and how I could
> resolve this error. Please let me know if I could help you with more
> information about this.
> Thanks
> Manav
> _______________________________________________
> users mailing list
> users_at_[hidden]

Jeff Squyres
Server Virtualization Business Unit
Cisco Systems