Open MPI logo

Open MPI User's Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Open MPI User's mailing list

From: Brian Barrett (brbarret_at_[hidden])
Date: 2006-03-10 08:35:35

On Mar 9, 2006, at 11:37 PM, Tom Rosmond wrote:

> Attached are output files from a build with the adjustments you
> suggested.
> setenv FC pgf90
> setenv F77 pgf90
> setenv CCPFLAGS -I/usr/include/gm
> ./configure --prefix=/users/rosmond/ompi --with-gm
> The results are the same.

Yes, I figured the failure would still be there. Sorry to make you
do the extra work, but I needed a build without the extra issues so
that I could try to get a clearer picture of what is going on.
Unfortunately, it looks like libtool (the GNU project to build
portable libraries) is doing something I didn't expect and causing
issues. I'm passing this on to a friend of Open MPI who works on the
Libtool project and is extremely good at figuring these issues out.
I'll relay back what he recommends, but it might not be until Monday.

> P.S. I understand that the mpi2 option is just a dummy. I use it
> because I am
> porting a code from an SGI Origin, which has full mpi2 one-sided
> support. This
> options makes it unnecessary to add my own dummy MPI2 routines to
> my source.
> My code has both MPI1 and MPI2 message passing options, so it's one
> of the
> reasons I like OPENMPI over MPICH.

Ok, I get a little nervous when I see that option, because it doesn't
do what most people expect ;). As long as you're fine with any call
to the one-sided functions invoking MPI error handlers, there should
be no problem. The good news is that Open MPI 1.1 will have complete
one-sided support.


> Brian Barrett wrote:
>> On Mar 9, 2006, at 2:51 PM, Tom Rosmond wrote:
>>> I am trying to install OPENMPI on a Linux cluster with 22 dual
>>> Opteron nodes and a Myrinet interconnect. I am having trouble
>>> with the build with the GM libraries. I configured with: ./
>>> configure --prefix-/users/rosmond/ompi --with-gm=/usr/lib64 --
>>> enable-mpi2-one-sided
>> Can you try configuring with --with-gm (no argument) and send the
>> output from configure and make again? The --with-gm flag takes as
>> an argument the installation prefix, not the library prefix. So in
>> this case, it would be --with-gm=/usr, which is kind of pointless,
>> as that's a default search location anyway. Open MPI's configure
>> script should automatically look in /usr/lib64. In fact, it looks
>> like configure looked there and found the right libgm, but
>> something went amuck later in the process. Also, you really don't
>> want to configure with the --enable-mpi2-one- sided flag. It will
>> not do anything useful and will likely cause very bad things to
>> happen. Open MPI 1.0.x does not have any MPI-2 onesided support.
>> Open MPI 1.1 should have a complete implementation of the onesided
>> chapter.
>>> and the environmental variables: setenv FC pgf90 setenv F77 pgf90
>>> setenv CCPFLAGS /usr/include/gm ! (note this non-standard location)
>> I assume you mean CPPFLAGS=-I/usr/include/gm, which shouldn't
>> cause any problems.
>>> The configure seemed to go OK, but the make failed. As you see at
>>> the end of the make output, it doesn't like the format of
>>> It looks to me that it is using a path (/usr/lib/.....)
>>> to 32 bit libraries, rather than 64 bit (/ usr/lib64/....). Is
>>> this correct? What's the solution?
>> I'm not sure at this point, but I need a build without the
>> incorrect flag to be able to determine what went wrong. We've
>> built Open MPI with 64 bit builds of GM before, so I'm surprised
>> there were any problems... Thanks, Brian
> <config.log.bz2>
> <config_out.bz2>
> <makeall_out.bz2>
> _______________________________________________
> users mailing list
> users_at_[hidden]

   Brian Barrett
   Open MPI developer