Open MPI logo

MTT Devel Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all MTT Devel mailing list

Subject: Re: [MTT devel] MTToGDS
From: Igor Ivanov (igor.ivanov_at_[hidden])
Date: 2010-02-10 04:18:50

I believe that it is just a warning and you can use mtt w/o analyzer that allow get additional info from output.


Jeff Squyres wrote:
On Feb 9, 2010, at 5:34 PM, Jeff Squyres (jsquyres) wrote:

6. Could you send detail info about the issue (ini-file, mtt.log with verbose info and command line), we will look on that.
Let me reproduce and simplify; I was using a fairly complex ini file... 

Oh, I see what happened -- I ran MTT manually on the command line and stepped through each of the phases manually, just to watch what was happening in each phase.  Something like this

mtt --file foo.ini --verbose --mpi-get
mtt --file foo.ini --verbose --mpi-install
mtt --file foo.ini --verbose --test-get
mtt --file foo.ini --verbose --test-build
mtt --file foo.ini --verbose --test-run

If I run just a single mtt invocation, the submitting for mpi install and test build seems to work.  However, there seems to be some built-in assumption that analyze::performance must be called...?  I was just running the "trivial" suites and trying to submit that.  Here's the --verbose output (I added the "GDS" verbose lines):

..lots of tests passing output
   Test: cxx_ring, np=16, variant=8: Passed
   Test: cxx_ring, np=16, variant=9: Passed
   Test: cxx_ring, np=16, variant=10: Passed
   Test: cxx_ring, np=16, variant=11: Passed
   Test: cxx_ring, np=16, variant=12: Passed
   ### Test progress: 8 of 8 section test executables complete. Moving on.
Reporter MTTGDS: cached for later submit
*** Run test phase complete
*** Reporter finalizing
Submitted MPI Install to GDS
Submitted Test Build to GDS
*** WARNING: Could not load module MTT::Test::Analyze::Performance::: Can't
    locate MTT/Test/Analyze/Performance/.pm in @INC (@INC contains:
    /usr/lib64/perl5/5.8.5/x86_64-linux-thread-multi /usr/lib/perl5/5.8.5
    /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4
    /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2
    /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0
    /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl/5.8.4
    /usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl/5.8.2
    /usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl/5.8.0
    /usr/lib/perl5/vendor_perl .) at (eval 1089) line 3.
..and oodles more errors just like this
Submitted Test Run to GDS
*** Reporter finalized

It looks like there is supposed to be some .pm file that I was supposed to have specified...?  I'm not quite sure why, though -- performance analyzers shouldn't be necessary for all tests.  We have oodles of correctness tests where performance isn't an issue, so that analysis is irrelevant.

One further question -- the initial email from Michael said that both libYAML and Syck are necessary.  Why both? says that Syck is the "old" interface and libYAML is preferred these days.

I'm testing -- unfortunately, I'm behind some proxies in the Cisco lab environment.  I'll see if I can add proxy support...


__________ Information from ESET NOD32 Antivirus, version of virus signature database 4852 (20100209) __________

The message was checked by ESET NOD32 Antivirus.