Open MPI logo

Hardware Locality Users' Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Users mailing list

Subject: Re: [hwloc-users] Having trouble getting CPU Model string on Windows 7 x64
From: Brice Goglin (Brice.Goglin_at_[hidden])
Date: 2014-01-28 03:57:30

Le 28/01/2014 09:46, Robin Scher a écrit :
> Hi, thanks for responding.
> The CPUModel is definitely available on this machine. A 32 bit process
> on the same machine correctly finds the model name using code that
> calls the cpuid inline assembly to get it, and the machine itself is a
> VM running on a Mac, and I get the same model name from the code on
> Mac and on a Linux VM running on the same machine as well. It seems to
> be an issue with the Windows port of hwloc, and possibly only with the
> 64 bit version (I haven't tried the 32 bit version yet).
> I am using the prebuilt binary on Windows. I haven't tried (and I'm
> not sure I want to try) building hwloc from source on Windows x64
> using MSVC, but I have found out so far today that Microsoft makes
> available a compiler intrinsic to get access to cpuid as a C function,
> and that's supposed to allow you to do the same kind of cpuid call
> work done previously as inline assembly. Perhaps someone out there is
> more familiar with this specific functionality in hwloc and can fix
> this for the 64 bit Windows build? I can take a stab at it, but like I
> said, the biggest hwloc development I've done is setting a flag in the
> configure script when I build on Unix.

Building for MSVC might be hard right now but somebody is working at it
(and I have a vcxproj to check in my INBOX).
I will debug a bit more to see if it's actually a 64bit cpuid problem on

> As a last question, where is the "CPUModel" documented about where it
> would appear? I was looking for that but couldn't find it.

There's a "object attributes" section in the doc. In the PDF, just look
for CPUModel. In the HTML, these sections are available from the
"related pages" tab.