Open MPI logo

Hardware Locality Users' Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Users mailing list

Subject: Re: [hwloc-users] GPU devices appear as PCI devices
From: Brice Goglin (brice.goglin_at_[hidden])
Date: 2012-11-20 10:30:19

Ask nvidia to make their cuda driver free, and to add them to sysfs :)

There's a cuda hwloc branch that will solve this. In the meantime, there are no nvidia osdevs.
Maybe look at hwloc/cuda.h and cudart.h, they give cuda device affinity without osdevs.


Guillermo Miranda <guillermo.miranda_at_[hidden]> a écrit :

>I am trying to detect GPus when traversing through the topology tree,
>but they appear as PCI devices instead of OS devices, so I can't
>the OS type against HWLOC_OBJ_OSDEV_GPU.
>I have enabled IO device discovery (HWLOC_TOPOLOGY_FLAG_IO_DEVICES) and
>made sure that hwloc's configure properly recognised Cuda (4.1).
>Here's what lstopo prints:
> <object type="PCIDev" os_index="536576"
>pci_busid="0000:83:00.0" pci_type="0302 [10de:1091] [00de:0042] a1"
> <info name="PCIVendor" value="nVidia Corporation"/>
> </object>
>Is this the expected behaviour? What can I do to make that GPU be
>as an OSDEV GPU object?
>Thanks in advance.
>WARNING / LEGAL TEXT: This message is intended only for the use of the
>individual or entity to which it is addressed and may contain
>information which is privileged, confidential, proprietary, or exempt
>from disclosure under applicable law. If you are not the intended
>recipient or the person responsible for delivering the message to the
>intended recipient, you are strictly prohibited from disclosing,
>distributing, copying, or in any way using this message. If you have
>received this communication in error, please notify the sender and
>destroy and delete any copies you may have received.
>hwloc-users mailing list