Le 11/07/2010 19:48, Jirka Hladky a écrit :

Hi all,

I have run into two bugs on PPC64 on 2.6.32 kernel.


lt-lstopo 1.0.1

BUG #1: No Socket information in lstopo output:


Machine (3654MB) + L2 #0 (4096KB)

L1 #0 (64KB) + Core #0

PU #0 (phys=0)

PU #1 (phys=1)

L1 #1 (64KB) + Core #1

PU #2 (phys=2)

PU #3 (phys=3)

Fixed in the latest version (tried hwloc-1.1a1r2301.tar.gz)

In 1.0.1, there's a patch that prevents us from showing invalid socket info on old kernels but it also prevents us from showing valid socket info on recent kernel. I reverted the commit in trunk (and in the upcoming 1.0.2).

BUG #2

On some PPC64, kernel 2.6.32 I have crash when running

$ lstopo a.txt

Segmentation fault (core dumped)

$ gdb /usr/local/bin/lstopo core.8771

Program terminated with signal 11, Segmentation fault.

#0 0x00000000100060b4 in .merge ()

It appears only on some PPC64 boxes.

This issue is also gone with in the latest version (tried hwloc-1.1a1r2301.tar.gz)

I wonder if you are aware of these problems. let me know if you need more details.

If you do "lstopo a.xml" first, does "lstopo --xml a.xml a.txt" crash as above? If so, please send a.xml so that I debug this.