Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: [hwloc-devel] Compiling hwloc 1.7 with NV support
From: Jiri Hladky (hladky.jiri_at_[hidden])
Date: 2013-04-19 18:56:20

Hi Brice,

how are you doing? I'm back at Red Hat:-) and I should have again more time
to test the hwloc and create rpms.

I have tried to build hwloc 1.7 on Fedora18 with NV support. I'm getting
this ERROR:

Hwloc optional build support status (more details can be found above):

Probe / display I/O devices: PCI GL
Graphical output (Cairo): yes
XML input / output: full
libnuma memory support: yes
Plugin support: no
topology-gl.c: In function 'hwloc_gl_query_devices':
topology-gl.c:91:41: error: 'NV_CTRL_PCI_DOMAIN' undeclared (first use in
this function)
topology-gl.c:91:41: note: each undeclared identifier is reported only once
for each function it appears in
make[2]: *** [topology-gl.lo] Error 1
make[2]: Leaving directory `/tmp/hwloc-1.7/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/tmp/hwloc-1.7/src'
make: *** [all-recursive] Error 1

Indeed, there is no NV_CTRL_PCI_DOMAIN MACRO defined in NVCtrl header files:

grep NV_CTRL_PCI_DOMAIN /usr/include/NVCtrl/NVCtrl*
=> empty

Could you please check it?

I'm also struggling with the following features when creating RPM for

  --disable-opencl Disable the OpenCL device discovery
  --disable-cuda Disable the CUDA device discovery using libcudart
  --disable-nvml Disable the NVML device discovery

I have tried to search for

yum whatprovides "*/cuda_runtime_api.h"

but without any luck. So it seems I can get rpm only with PCI and GL

What's your opinion on it? Do you know what other Linux distros are doing?