Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: Re: [hwloc-devel] merging plugins?
From: Samuel Thibault (samuel.thibault_at_[hidden])
Date: 2012-09-25 05:13:34

Brice Goglin, le Tue 25 Sep 2012 11:08:04 +0200, a écrit :
> >> We have the "core_xml" component (generic xml support) and "xml_libxml"
> >> + "xml_nolibxml" backends behind that. I am fine with removing the
> >> "core_" prefix, but I wonder if we should keep the "xml_" prefix for the
> >> latter.
> > I'd say we should keep it. Just like I wanted to use core_linux_x86 (as
> > opposed to core_linux)
> Keep which one? "core" or "core" and "xml" ?


> > Well, that still looks hardcoded to me. Actually, a simple way would
> > be to order all plugins in just one list by priorities. When loading a
> > plugin, one checks whether the exclusion point of the plugin was
> > already filled or not, and load the plugin accordingly
> The good thing about this is that XML and synthetic can set exclusion
> But we obviously don't want cuda, ... to set the ADDITIONAL exclusion
> flag. So setting a exclusion flag would mean "I don't want any plugin of
> this type to be enabled" (different from "I don't want any plugin with
> this exclusion flag to be set).

Right, like in Debian packages, there are separate "provides" and
"conflicts". Usually one both provide and conflict, but one can do
either separately.