Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: Re: [hwloc-devel] merging the valarray branch (with a better name)
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2012-08-24 09:20:03

On Aug 24, 2012, at 7:09 AM, Brice Goglin wrote:

>> Another name suggestion: cached_floats (cached_doubles)
> It's not really about caching, it's more about annotating the topology
> by merging multiple inputs together (XML topology + benchmark outputs +
> application info) inside the same XML file.

How about just "annotations", then?

>> , why not make the mechanism more general? E.g., the values array should be a union, with an enum indicating its type, and support a small number of intrinsic types: float (or double), string, int (and/or long?).
> I thought about that but I wasn't sure it was worth doing it. When you
> say type, are you talking about the type that appears in the array of
> values, or about the global annotation type?
> I though about doing this
> struct values {

I was thinking more like:

struct annotation {
  char *name;
  int array_len;
  enum { INT, LONG, FLOAT, DOUBLE } value_type;
  union {
     int *i_values;
     long *l_values;
     float *f_values;
     double *d_values;
     /* other types if you want them */
  } values;
  unsigned *indexes; /* I'm not sure what this is for? */

Jeff Squyres
For corporate legal information go to: