Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: Re: [hwloc-devel] merging the valarray branch (with a better name)
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2012-08-24 05:46:00

On Aug 24, 2012, at 4:26 AM, Brice Goglin wrote:

> The question that remains is about the naming. Right now, it's
> "valarray" but it don't like it. What it really means is "custom array
> of float values". Maybe just "values", or "floats", or "custom floats",
> or ... ?

Random question: why floats and not doubles?

Another name suggestion: cached_floats (cached_doubles)

If the goal is to be able to store some data that will also show up in the XML (and text/gui output?), why not make the mechanism more general? E.g., the values array should be a union, with an enum indicating its type, and support a small number of intrinsic types: float (or double), string, int (and/or long?).

Then you can call it "cached_values", or some such.

Jeff Squyres
For corporate legal information go to: