Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: [hwloc-devel] merging the valarray branch (with a better name)
From: Brice Goglin (Brice.Goglin_at_[hidden])
Date: 2012-08-24 04:26:39

I got some positive feedback from the user who requested what's in the
"valarray" branch so I am planning to include it in v1.6.

For the record, it's about annotating objects with randoms values.
Before that, we can annotate objects with strings only ("info"). This
adds a structure containing a name, a number of elements, an array of
indexes, and an array of floats. Typically, you would use it to store
things like HW benchmark results there, and applications would just load
the annotated XML topology to get benchmark results too.

The configurable number of elements and the array of indexes lets you
store a lot of things, even 2D or 3D matrices (you just need to compute
a 1D index from the 2D/3D coordinates). Floats are not perfect but they
should be enough for most cases.

The question that remains is about the naming. Right now, it's
"valarray" but it don't like it. What it really means is "custom array
of float values". Maybe just "values", or "floats", or "custom floats",
or ... ?