Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: Re: [hwloc-devel] Something lighter-weight than XML?
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2011-09-01 14:31:21

On Sep 1, 2011, at 12:17 PM, Brice Goglin wrote:

> Support for the most useful attributes would be done within a couple
> hours. The annoying thing is to support all attributes, distances, ...

If you kruft up some of the infrastructure and some examples, I could volunteer some grunt work to fill in the rest.

> Also we'd need to find a good name for this new backend. Something away
> from "text" because we already have the txt and ncurses outputs in
> lstopo :) Maybe "hwloc". hwloc_topology_export_hwlocbuffer() and "lstopo
> foo.hwloc" :) Or "htx" for "hwloc tiny xml".

Hah! htx might work. Or:

hst: hwloc simple text
hnx: hwloc NoXML
htt: hwloc trivial text
simple: obvious
serialized: obvious
string: obvious
newline: because the fields are newline-delimited


Jeff Squyres
For corporate legal information go to: