I am waiting for this troll to settle down before pushing some related
changes (add a (cpubind?) support flag and a hwloc-bind option).
I agree that "last" is better than "current". And I agree that
"lastcpuexec" isn't perfect, but I didn't see anything better so far :)
Le 14/02/2011 15:19, Samuel Thibault a écrit :
> Jeff Squyres, le Mon 14 Feb 2011 14:56:45 +0100, a écrit :
>> On Feb 14, 2011, at 8:23 AM, Samuel Thibault wrote:
>>>> Let's not use "cpu" -- how about get_current_cpubind? (vs. get_cpubind)
>>> The point is precisely that it's not the cpu binding, but where the
>>> thread is actually _running_ precisely.
>> Hmm; ok. I like the word "current" in here, somehow. Gives the connotation that it might change in the future (if it's not bound).
> Well, I prefer "last" because it even expresses that it's probably
> already expired :)
>> Maybe get_current_cpuset?
> It seems to me that may bring confusion with cpubind (and linux' cpuset
> :) )
> hwloc-devel mailing list