Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: Re: [hwloc-devel] Man pages and gather-topology
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2011-01-20 07:26:38

I used my Mac, which I've used to make all the other hwloc tarballs.

I know that doxygen had been updated since I built the 1.1 tarball, though -- it's possible that the others have been updated, too. I'll check.

Did you notice the font selection for the titles in I'm pretty sure that this is as result of the doxygen update.

I don't know where the -e suffixes came from; I'll dig into that. I had to separate out the massive sed-with-a-million-e's in doc/ because I discovered that OS X's sed only accepts one -e per sed.

On a side note, I'm having problem with a fresh hwloc 1.1 branch checkout on RHEL 5.5 (i.e., not the tarball) -- this is during make install:

/usr/bin/install: cannot stat `./doxygen-doc/man/man3/HWLOC_API_VERSION.3': No such file or directory

But a fresh hwloc 1.1 branch works fine on my mac. Sigh.

I'll keep checking...

On Jan 20, 2011, at 7:18 AM, Brice Goglin wrote:

> Le 20/01/2011 13:01, Brice Goglin a écrit :
>> The online tarball doesn't build here either. It doesn't contain the
>> gather-topology.1in manpage. But make dist (and distcheck) in v1.1
>> branch work fine here.
>> I don't know what happen during your make dist. Apart from the missing
>> manpage. Your tarball contains all files that configure and make
>> generates (Makefile, .deps, .o, .libs). Your doxygen also created
>> additional files with -e prefix for each expected html and manpages.
> I meant "-e" *suffix*.
> Your tarball:
> $ tar tvfz hwloc-1.1.1rc1.tar.gz | grep get_api_
> -rw-r--r-- jsquyres/staff 34 2011-01-19 14:21 hwloc-1.1.1rc1/doc/doxygen-doc/man/man3/hwloc_get_api_version.3
> -rw-r--r-- jsquyres/staff 34 2011-01-19 14:21 hwloc-1.1.1rc1/doc/doxygen-doc/man/man3/hwloc_get_api_version.3-e
> My tarball:
> $ tar tvfz hwloc-1.1.1rc1r3097.tar.gz | grep get_api_
> -rw-r--r-- bgoglin/users 34 2011-01-20 13:12 hwloc-1.1.1rc1r3097/doc/doxygen-doc/man/man3/hwloc_get_api_version.3
>> I don't see anything wrong with get_api_version. Once I manually worked
>> around the missing manpage, make worked fine.
>> FWIW, you used autoconf 2.68 and doxygen 1.7.2. I use 2.67 and 1.7.1.
> Upgrading from doxygen 1.7.1 to 1.7.3 didn't change anything (it didn't
> create "-e" suffixed files).
> Brice
> _______________________________________________
> hwloc-devel mailing list
> hwloc-devel_at_[hidden]

Jeff Squyres
For corporate legal information go to: