Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: Re: [hwloc-devel] [hwloc-announce] Hardware locality (hwloc) v1.1rc1 released
From: Brice Goglin (Brice.Goglin_at_[hidden])
Date: 2010-11-10 11:27:49

Le 10/11/2010 15:02, Jirka Hladky a écrit :
>>> 2) hwloc-bind --get --membind is not working for me (RHEL 6.0)
>>> $ hwloc-bind --membind node:1 --mempolicy interleave -- hwloc-bind --get
>>> -- membind
>>> hwloc_get_membind failed (errno 22 Invalid argument)
>> You get the same error when running only "hwloc-bind --get --membind",
>> right?
> Yes:
> $ hwloc-bind --get --membind
> hwloc_get_membind failed (errno 22 Invalid argument)
>> I am not sure about this one. Do you have NUMA support in your kernel?
>> Is your machine NUMA? Can you send the gather-topology tarball ? (if we
>> don't have it already :))
> Yes, it's a NUMA box with NUMA support in kernel.

Unfortunately, I can't reproduce. I tried with your tarball, with a
Redhat 5 machine, with a similar Nehalem-based machine running Debian.

Can you try to debug this? I'd like to know if EINVAL is returned by the
kernel or by hwloc. You'd have to open src/topology-linux.c, go in
function hwloc_linux_get_thisthread_membind() and add some printf there
to check where EINVAL comes from.