Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: Re: [hwloc-devel] 1.0-rc1
From: Bert Wesarg (bert.wesarg_at_[hidden])
Date: 2010-03-22 17:27:28

On Mon, Mar 22, 2010 at 21:49, Jeff Squyres <jsquyres_at_[hidden]> wrote:
> On Mar 22, 2010, at 4:34 PM, Bert Wesarg wrote:
>> > Same question again :)
>> I suspect, I can't propose API changes after that, right? ;-)
> It would be good, yes.  :-)
> Have you had a good look around hwloc?  I.e., do you have a feel for whether you will be suggesting any more API changes?

Only a cursory one and mostly inside the linux backend. Here are some
thoughts: Thats more a personal favor, but anyway: In case of the
binary cpuset operations I find the '<res> = <arg1> op <arg2>' style
more flexible, than the current '<arg1> op= <arg2>' style. I would
also rename hwloc_cpuset_clearset() to hwloc_cpuset_andnotset(), so it
fits to the _{or,and,xor,not}set naming style (i.e. they are named
after the bit operation).

I myself don't expect any API changes from me anymore.