Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: Re: [hwloc-devel] [PATCH] Replace readdir() with readdir_r()
From: Samuel Thibault (samuel.thibault_at_[hidden])
Date: 2010-03-18 18:25:05

Brice Goglin, le Thu 18 Mar 2010 22:58:35 +0100, a écrit :
> Bert Wesarg wrote:
> > Make the linux backend more re-entrant safe by using readdir_r() instead
> > of readdir().
> Changing so many lines because of bugs that don't exist yet doesn't
> look like a good idea to me.

Err, they do already exist. We've just documented that it was safe to
work on separate topology objects in different threads, so readdir is
indeed an issue :)

> If we ever want to parallelize the bottom of the discovery stack (or
> whatever needs reentrancy in such very low-level discovery routines),

It's not about parallelization of the backend here, but about the
application calling it several times in parallel.