Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: Re: [hwloc-devel] [PATCH] Replace readdir() with readdir_r()
From: Brice Goglin (Brice.Goglin_at_[hidden])
Date: 2010-03-18 17:58:35

Bert Wesarg wrote:
> Make the linux backend more re-entrant safe by using readdir_r() instead
> of readdir().

Changing so many lines because of bugs that don't exist yet doesn't look
like a good idea to me. If we ever want to parallelize the bottom of the
discovery stack (or whatever needs reentrancy in such very low-level
discovery routines), there will be many other changes to do anyway. So
we'll see later, when we'll know what we want and where we actually need