Open MPI logo

Hardware Locality Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Hardware Locality Development mailing list

Subject: [hwloc-devel] last API change
From: Brice Goglin (Brice.Goglin_at_[hidden])
Date: 2009-10-20 01:41:29


As a last API change before 0.9.1, I think we need to rename
get_cache_covering_obj(). We currently have get_cache_covering_cpuset()
which does what it says. However we also have get_cache_covering_obj()
which does not return a cache above obj but returns a cache above obj
*and* shared with somebody else (the cpuset of the returned cache is
strictly different than obj). If anybody has a good name, please let me
know. Maybe get_shared_cache_covering_obj() or
get_cache_covering_obj_and_shared() ? I'll fix this later today.