Hi Jeff,

Comments are in the text

Jeff Squyres a écrit :
On Nov 30, 2010, at 6:44 AM, Pascal Deveze wrote:

I have commited all my last changes in bitbucket, including those that follows.

I got a checkout, and still have some problems/questions.  More below.

If you do the IM thing, ping me on IM (I sent you my IDs in an off-list email).

I am not on AIM nor on google talk. Sorry. In the case you think it is necessary, I could ask for an ID.
We could also continue with email.

Do we have the MPIU functions?  Or is that an MPICH2-specific thing?
I have put in comments this last "AC_DEFINE":
# Open MPI does not have the MPIU functions
# AC_DEFINE(HAVE_MPIU_FUNCS,1,[Define if MPICH2 memory tracing macros defined]) 


I see that you moved confdb/aclocal_cc.m4 to acinclude.m4.  Shoudn't we just -I confdb instead to get all of their .m4 files?

This has been done during the last porting (years ago).
I have now changed this: All confdb/.m4 files are now copied from MPICH2. Only the definition of PAC_FUNC_NEEDS_DECL is still kept in acinclude.m4.
If I do not so, configure is still blocking on this macro.
All seems working well so. If you have any clue about this, I will take it !

I see that we have the whole romio/confdb directory, so it seems like we should use that tree rather than copy to acinclude.m4.
I agree with you. But, as I said, I have a problem with the macro PAC_FUNC_NEEDS_DECL and the only way to solve it is to put it in acinclude.m4.
But I note that when I get an hg clone of your repo:

- there's no .hgignore file -- making "hg status" difficult.  In your SVN+HG tree, can you run ./contrib/hg/build-hgignore.pl and commit/push the resulting .hgignore?  That would be most helpful.
I have done it, and pushed.
- ompi/mca/io/romio/romio/adio/include/romioconf.h.in is in the hg repo, but should not be (it's generated).
I removed it and pushed the modification.
- I don't see a romio/acinclude.m4 file in the repo, so whatever you did there doesn't show up for me.  
I see the file romio/romio/acinclude.m4 in bitbucket:

- I tried to add an ompi/mca/io/romio/romio/autogen.sh executable file that contained:

autoreconf -ivf -I confdb

and that seems to make everything work.  Can you confirm/double check?

Yes I tried what you suggest (without acinclude.m4), it seems that everything work:
autoreconf -ivf -I confdb
autoreconf: Entering directory `.'
autoreconf: configure.in: not using Gettext
autoreconf: running: aclocal -I confdb --force
autoreconf: configure.in: tracing
autoreconf: running: libtoolize --copy --force
libtoolize: putting auxiliary files in AC_CONFIG_AUX_DIR, `confdb'.
libtoolize: copying file `confdb/ltmain.sh'
libtoolize: Consider adding `AC_CONFIG_MACRO_DIR([m4])' to configure.in and
libtoolize: rerunning libtoolize, to keep the correct libtool macros in-tree.
libtoolize: Consider adding `-I m4' to ACLOCAL_AMFLAGS in Makefile.am.
libtoolize: `AC_PROG_RANLIB' is rendered obsolete by `LT_INIT'
autoreconf: running: /homes/openmpi/tools/2010-10-12/bin/autoconf --include=confdb --force
autoreconf: running: /homes/openmpi/tools/2010-10-12/bin/autoheader --include=confdb --force
autoreconf: running: automake --add-missing --copy --force-missing
autoreconf: Leaving directory `.'

If I try to generate the whole MPI, autogen.sh works but configure fails in the romio directory.
If I try your autoreconf, then it works for ROMIO.
===== This does not work without acinclude.m4 ==================
./configure --prefix=$HOME/bitbucket/new-romio-for-openmpi/install --disable-ipv6 --with-openib=${OFED_BUILDROOT}/usr --enable-openib-connectx-xrc --enable-contrib-no-build=libnbc,vt --with-io-romio-flags="CFLAGS=-I$LUSTRE_PATH/usr/include/ --with-file-system=ufs+nfs+lustre"

===== This works without acinclude.m4 ==================
cd ompi/mca/io/romio/romio
autoreconf -ivf -I confdb
cd -
./configure --prefix=$HOME/bitbucket/new-romio-for-openmpi/install --disable-ipv6 --with-openib=${OFED_BUILDROOT}/usr --enable-openib-connectx-xrc --enable-contrib-no-build=libnbc,vt --with-io-romio-flags="CFLAGS=-I$LUSTRE_PATH/usr/include/ --with-file-system=ufs+nfs+lustre"

My conclusion is: There is something to change in autogen.sh to deal with ROMIO (call autoreconf -ivf -I confdb). In that case, the file acinclude.m4 is no more usefull.

In configure.in, please update the version number in AM_INIT_AUTOMAKE.
AM_INIT_AUTOMAKE(io-romio, 1.0.0, 'no')
is changed to
AM_INIT_AUTOMAKE(io-romio, 1.0.1, 'no')

Can we use whatever the real ROMIO version number is?  

It seems that real version is 1.2.6 (see README).  So I changed it, committed and pushed.