Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] [EXTERNAL] SPARC V8+ question
From: Barrett, Brian W (bwbarre_at_[hidden])
Date: 2014-01-30 14:57:53

Following up on the mailing list, Paul and I think this is gcc being silly; it didn't pass the right architecture flag to the assembler, which barfed at the Sparc V9 instruction (compare and swap). So the test worked as it should and we'll figure out the gcc thing as we go.

I've filed a change for v1.7 to fix the warning message. The reference to FFLAGS wasn't the only problem, so it's a slightly more generic error message now.


On 1/29/14 4:10 PM, "Paul Hargrove" <phhargrove_at_[hidden]<mailto:phhargrove_at_[hidden]>> wrote:

I know Open MPI dropped support for the SPARC V8 ABI some time ago.
So, I configured with CC="gcc -mv8plus", but I still get:

checking if have Sparc v8+/v9 support... no
configure: WARNING: Sparc v8 target is not supported in this release of Open MPI.
configure: WARNING: You must specify the target architecture v8plus
configure: WARNING: (cc: -xarch=v8plus, gcc: -mcpu=v9) for CFLAGS, CXXFLAGS,
configure: WARNING: FFLAGS, and FCFLAGS to compile Open MPI in 32 bit mode on
configure: WARNING: Sparc processors
configure: error: Can not continue.

So, I am wondering if there is something flawed in the "have Sparc v8+/v9 support" or if gcc's "-mv8plus" is flawed.
Of course, I will follow the advise in the warning and use -mcpu=v9 instead of -mv8plus, but don't see why the later didn't work. Any ideas what is going on?

And since this was found in 1.7.4rc2:


Paul H. Hargrove                          PHHargrove_at_[hidden]<mailto:PHHargrove_at_[hidden]>
Future Technologies Group
Computer and Data Sciences Department     Tel: +1-510-495-2352
Lawrence Berkeley National Laboratory     Fax: +1-510-486-6900
  Brian W. Barrett
  Scalable System Software Group
  Sandia National Laboratories