Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] [EXTERNAL] Re: [OMPI svn] svn:open-mpi r28202 - in trunk: ompi/runtime opal/mca/memory/linux
From: Barrett, Brian W (bwbarre_at_[hidden])
Date: 2013-03-22 11:53:22

On 3/22/13 9:35 AM, "Ralph Castain" <rhc_at_[hidden]> wrote:

>On Mar 22, 2013, at 8:23 AM, "Barrett, Brian W" <bwbarre_at_[hidden]>
>> On 3/22/13 9:17 AM, "Ralph Castain" <rhc_at_[hidden]> wrote:
>>> I'm afraid this still doesn't work for me - on my Centos box:
>>> ../../../ompi/.libs/ undefined reference to
>>> `opal_memory_linux_malloc_init_hook'
>>> I tried it with a brand new checkout of the trunk. Any ideas?
>> Can you run nm on the built libopen-pal and see if
>> opal_memory_linux_malloc_init_hook() is in there (and whether it's
>> or private)?
>Perhaps the difference stems from my platform file?

That would be the issue. There's a bug in the memory-linux component's
configure such that it sets the defines that say it's going to build when
it's not actually going to build. I have a (bad) fix for this problem and
am trying to see if I can find a less awful solution.

Long term, this is a gentle reminder that I really need to do some more
overhaul of the configure system so that we don't run configure macros for
components that won't build.


  Brian W. Barrett
  Scalable System Software Group
  Sandia National Laboratories