Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] MPI_THREAD_MULTIPLE testing on trunk
From: Jeff Squyres (jsquyres_at_[hidden])
Date: 2012-08-02 10:25:53

On Aug 1, 2012, at 9:44 AM, Christopher Yeoh wrote:

> I was wondering if anyone else recently had tried to run trunk
> configured with --enable-mpi-thread-multiple and an MPI program that
> passed MPI_THREAD_MULTIPLE to MPI_Init_thread on a machine using the
> openib btl?

I run one of my MTT configs with --enable-mpi-thread-multiple, but only run single-threaded apps (i.e., MPI_THREAD_SINGLE). This just checks the bozo case.

> I'm seeing even very basic programs hang. If it is working for you,
> what architecture are you running on? (may help me debug what is going
> on with my setup). In contrast, 1.6 on the same machines work fine for
> me (well as fine as MPI_THREAD_MULTIPLE has ever worked anyway ;-)

I wonder what broke on the trunk...

Jeff Squyres
For corporate legal information go to: