Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] hang with launch including remote nodes
From: Eugene Loh (eugene.loh_at_[hidden])
Date: 2012-06-20 23:48:29

On 06/19/12 23:11, Ralph Castain wrote:
> Also, how did you configure this version?

> If you had --disable-static, then there was a bug that would indeed cause a hang. Just committing that fix now.
I still get a hang even with r26623.
> On Jun 19, 2012, at 9:01 PM, Ralph Castain wrote:
>> See if it works with -mca orte_use_common_port 0

I get a segfault:

[remote1:01409] *** Process received signal ***
[remote1:01409] Signal: Segmentation Fault (11)
[remote1:01409] Signal code: Address not mapped (1)
[remote1:01409] Failing at address: 2c
[Signal 11 (SEGV)]



[remote1:01409] *** End of error message ***
Segmentation Fault (core dumped)

>> On Jun 19, 2012, at 8:31 PM, Eugene Loh wrote:
>>> I'm having bad luck with the trunk starting with r26609. Basically, things hang if I run
>>> mpirun -H remote1,remote2 -n 2 hostname
>>> where remote1 and remote2 are remote nodes.