Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] 1.5.5rc1 tested: REGRESSION on FreeBSD
From: Paul H. Hargrove (PHHargrove_at_[hidden])
Date: 2011-12-14 01:17:50

My OpenBSD and NetBSD testers have the same behavior, but now I see that
I was at warned...

On all the affected systems I found the following (modulo the system
tuple) in the configure output:
> checking which OS support to include... Unsupported!
> (x86_64-unknown-openbsd5.0)
> configure: WARNING:
> ***********************************************************
> configure: WARNING: *** hwloc does not support this system.
> configure: WARNING: *** hwloc will *attempt* to build (but it may not
> work).
> configure: WARNING: *** hwloc run-time results may be reduced to
> showing just one processor.
> configure: WARNING: *** You have been warned.
> configure: WARNING: *** Pausing to give you time to read this message...
> configure: WARNING:
> ***********************************************************

Clearly my failures are "known" to somebody.

However, I have multiple "issues" with the current behavior.
1) At an minimum the WARNING mention --without-hwloc
2) Is this "build and pray" approach to unknown platforms really wise?
3) Shouldn't something appear in the README about this? The
--without-hwloc option doesn't even appear in README.

Even configured using --without-hwloc I cannot build on FreeBSD, but
I'll start another thread for that.


On 12/13/2011 9:35 PM, Paul H. Hargrove wrote:
> I am seeing build failures on the following:
> FreeBSD-8.2-RELEASE on amd64
> FreeBSD-7.2-RELEASE on amd64
> FreeBSD-6.3-RELEASE on amd64
> All three fail with the same error:
>> CCLD opal_wrapper
>> ../../../opal/.libs/ undefined reference to
>> `opal_hwloc122_hwloc_backend_sysfs_init'
>> ../../../opal/.libs/ undefined reference to
>> `opal_hwloc122_hwloc_set_linux_hooks'
>> ../../../opal/.libs/ undefined reference to
>> `opal_hwloc122_hwloc_backend_sysfs_exit'
>> ../../../opal/.libs/ undefined reference to
>> `opal_hwloc122_hwloc_look_linux'
> Apparently something thinks this is Linux.
> I tried 1.5.4 on the FreeBSD-8.2 platform (no patience for the other 2).
> With the addition of --disable-io-romio, I can "gmake all install
> check" ompi-1.5.4 on FreeBSD-8.2/amd64 w/o incident.
> So, this hwloc122 problem appears to be a REGRESSION relative to the
> 1.5.4 release.
> Jeff, Brian and George have all had accounts on our group's machines
> at one time or another.
> So, I can probably arrange access to the FreeBSD-8.2 host for somebody
> if necessary.
> -Paul
> On 12/13/2011 8:36 PM, Jeff Squyres wrote:
>> In the usual place:
>> Please test! I would really like to get this out by the end of the
>> week.
>> Two issues *might* still be considered for this release:
>> Putting back the openib minor fixes
>> Making the "your SM file is on an NFS!" warning disable-able
>> (this is the v1.4 ticket)
>> They would both need to be fixed in the *immediate future* to be
>> considered.

Paul H. Hargrove                          PHHargrove_at_[hidden]
Future Technologies Group
HPC Research Department                   Tel: +1-510-495-2352
Lawrence Berkeley National Laboratory     Fax: +1-510-486-6900