Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: [OMPI devel] RFC: Rename ompi/include/mpi_portable_platform.h
From: Ralph Castain (rhc_at_[hidden])
Date: 2010-02-11 12:33:28

WHAT: Rename ompi/include/mpi_portable_platform.h to be opal/include/opal_portable_platform.h

WHY: The file includes definitions and macros that identify the compiler used to build the system, etc.
              The contents actually have nothing specific to do with MPI.

WHEN: Weekend of Feb 20th

I'm trying to rationalize the ompi_info system so that people who build different layers can still get a report of the MCA params, build configuration, etc. for the layers they build. Thus, there would be an "orte_info" and "opal_info" capability. Each would report not only the info for their own layer, but the layer(s) below. So ompi_info remains unchanged, orte_info reports ORTE and OPAL info, etc.

The problem I encountered is that the referenced file is required for the various "info" tools, but it exists in the MPI layer. Since the file is only accessed at build time, I can go ahead and reference it from within "orte_info" and "opal_info", but it does somewhat break the abstraction barrier to do so.

Given that the info in the file has nothing to do with MPI itself, it seemed reasonable to move it to opal...barring arguments to the contrary.