Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] require newer autoconf?
From: Brian Barrett (brbarret_at_[hidden])
Date: 2009-03-17 21:06:01

I'd rather not. I have a couple of platforms with 2.59 installed, but
not 2.60+. I really don't want to have to install my own autotools
because of some bug that doesn't affect me.

I don't, however, have a problem with forcing users to upgrade in
order to get support for build-related issues. The version of
Autoconf used is in config.log, so it's not hard to find which version
the user actually used.


On Mar 17, 2009, at 7:00 PM, Jeff Squyres wrote:

> Per this thread:
> It took a *loooong* time to figure out that an outdated Autoconf
> install was the culprit of the "restrict" mess. The issue is that
> somewhere between v2.61 and v2.63, Autoconf changed the order of
> looking for "restrict"-like keywords -- AC 2.63 has the "good"
> order; AC 2.61 has the "bad" order (hence, PGI worked for me with AC
> 2.63, but barfed for Mostyn with AC 2.61).
> Should we have our force the use of AC 2.63 and above?
> (currently, it forces 2.59 and above)
> --
> Jeff Squyres
> Cisco Systems
> _______________________________________________
> devel mailing list
> devel_at_[hidden]