Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] RFC: libopen-rte --> libompi-rte
From: Brian W. Barrett (brbarret_at_[hidden])
Date: 2008-11-06 13:13:09

On Thu, 6 Nov 2008, Jeff Squyres wrote:

> WHAT: Rename libopen-rte to be libompi-rte (and probably other supporting
> text)
> WHY: ORTE is really quite specific to OMPI. We decided long ago that ORTE
> would not split off from OMPI, and it has been specifically tailored for
> OMPI. Indeed, Ralph has recently been expanding "ORTE" to "OMPI Run Time
> Environment". So let's name the library what it really is.

Does it really hurt anything to leave the name as is? I know you love
wrapper compilers, but there are a significant number of people who can't
use them for one reason or another (like my case, krufty Makefiles I don't
have control over). It seems like there's almost no upside, and a
significant downside for others.