Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] gdb libmpi.dylib on Leopard
From: Ralf Wildenhues (Ralf.Wildenhues_at_[hidden])
Date: 2008-09-19 17:08:10


I asked Peter O'Gorman about this issue, and he said

| I believe that running dsymutil on the generated lib would then create a
| libfoo.dSYM in the .libs directory conatining all the necessary
| debugging information, which could be used for debugging the library in
| the build tree (gdb should find it sitting there next to the original
| library and use the debug information in the .dSYM). Libtool-2.2.6 does
| run dsymutil and create the .dSYM though...
| There should be a libmpi.dylib in a .libs directory and a
| libmpi.dylib.dSYM directory next to it.

Also, he said that it could help if you reported a bug at
<>, under the notion that the
more people file bugs with them, the more they will understand
what problems users have with the dsymutils issues.


* Aurélien Bouteiller wrote on Fri, Sep 19, 2008 at 09:44:46PM CEST:
> Ok,
> I didn't forgot to rerun (I even erased the libltdl, and
> various libtool wrappers that are generated at autogen/configure time). I
> checked the link Ralf submitted to our attention. This is exactly the
> same problem, or at least the same symptoms. The last version of libtool
> runs dsymutil on the created .so/.dylib, but the bad thing is that
> dsymutil returns similar warning message about missing ".lax" files.
> Therefore, even running it manually on the .dsym does not help.
> I upgraded (compiled my own copy) my gcc to 4.3.2 (you should do it too,
> Jeff, the experimental have been giving me headaches in the past). Now, I
> also have the same warning messages for internal libs of gcc than for
> open MPI. This leads me to believe this is not an Open MPI bug, but more
> probably a libtool/ld issue.
> I'll switch to linux for my devel for now, but if you have any success
> story...
> Aurelien
> Le 19 sept. 08 à 15:20, Jeff Squyres a écrit :
>> I get the same problem on my MBP with 10.5.5. However, I'm running
>> the gcc from
>> -----
>> [15:16] rtp-jsquyres-8713:~/mpi % gcc --version
>> gcc (GCC) 4.3.0 20071026 (experimental)
>> ...
>> -----
>> Not the /usr/bin/gcc that ships with Leopard. I don't know if that
>> matters or not.
>> I'm using AC 2.63, AM 1.10.1, LT 2.2.6a with a fairly vanilla build of
>> Open MPI:
>> ./configure --prefix=/Users/jsquyres/bogus --disable-mpi-f77 --
>> enable-mpirun-prefix-by-default
>> Here's what happens -- I fire up an MPI program and it deadlocks. I
>> attach to an MPI process PID with gdb (I am using /usr/bin/gdb -- the
>> Leopard-shipped gdb). I get oodles of messages like Aurelien's:
>> -----
>> warning: Could not find object file "/data/jsquyres/svn/ompi/
>> ompi/.libs/libmpi.lax/libdatatype.a/convertor.o" - no debug
>> information available for "convertor.c".
>> warning: Could not find object file "/data/jsquyres/svn/ompi/
>> ompi/.libs/libmpi.lax/libdatatype.a/copy_functions.o" - no debug
>> information available for "copy_functions.c".
>> warning: Could not find object file "/data/jsquyres/svn/ompi/
>> ompi/.libs/libmpi.lax/libdatatype.a/copy_functions_heterogeneous.o" -
>> no debug information available for "copy_functions_heterogeneous.c".
>> -----
>> On Sep 19, 2008, at 2:31 PM, Ralf Wildenhues wrote:
>>> * Aurélien Bouteiller wrote on Fri, Sep 19, 2008 at 08:02:40PM CEST:
>>>> Thanks Ralf for the support. I upgraded to libtool 2.2.6 and it
>>>> didn't
>>>> solved the problem though. Still looking for somebody to confirm
>>>> that
>>>> its working or not working on their Mac.
>>> Did you rerun All I know is that your report looks
>>> really
>>> similar to <> and that
>>> one is apparently solved with Libtool 2.2.6.
>>> If yours is still broken, then some more details would be nice.