Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] -display-map
From: Greg Watson (g.watson_at_[hidden])
Date: 2008-09-19 09:18:04


The problem we're seeing is just with the head node. If I specify a
particular IP address for the head node in the hostfile, it gets
changed to the FQDN when displayed in the map. This is a problem for
us as we need to be able to match the two, and since we're not
necessarily running on the head node, we can't always do the same
resolution you're doing.

Would it be possible to use the same address that is specified in the
hostfile, or alternatively provide an XML attribute that contains this



On Sep 11, 2008, at 9:06 AM, Ralph Castain wrote:

> Not in that regard, depending upon what you mean by "recently". The
> only changes I am aware of wrt nodes consisted of some changes to
> the order in which we use the nodes when specified by hostfile or -
> host, and a little #if protectionism needed by Brian for the Cray
> port.
> Are you seeing this for every node? Reason I ask: I can't offhand
> think of anything in the code base that would replace a host name
> with the FQDN because we don't get that info for remote nodes. The
> only exception is the head node (where mpirun sits) - in that lone
> case, we default to the name returned to us by gethostname(). We do
> that because the head node is frequently accessible on a more global
> basis than the compute nodes - thus, the FQDN is required to ensure
> that there is no address confusion on the network.
> If the user refers to compute nodes in a hostfile or -host (or in an
> allocation from a resource manager) by non-FQDN, we just assume they
> know what they are doing and the name will correctly resolve to a
> unique address.
> On Sep 10, 2008, at 9:45 AM, Greg Watson wrote:
>> Hi,
>> Has there been a change in the behavior of the -display-map option
>> has changed recently in the 1.3 branch. We're now seeing the host
>> name as a fully resolved DN rather than the entry that was
>> specified in the hostfile. Is there any particular reason for this?
>> If so, would it be possible to add the hostfile entry to the output
>> since we need to be able to match the two?
>> Thanks,
>> Greg
>> _______________________________________________
>> devel mailing list
>> devel_at_[hidden]
> _______________________________________________
> devel mailing list
> devel_at_[hidden]