Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

Subject: Re: [OMPI devel] Memchecker: breaks trunk again
From: Ralph H Castain (rhc_at_[hidden])
Date: 2008-04-21 09:51:51

As an FYI for anyone similarly afflicted:

The only solution I have found is to gut the file

# MCA_memchecker_valgrind_CONFIG([action-if-found], [action-if-not-found])
# -----------------------------------------------------------

        happy=0 # none_needed
        happy_value=0 # none_needed
        memchecker_valgrind_happy=0 # This should suffice to get rid of the

Nothing else will allow you to build unless you have the valgrind headers
installed on your machine.


On 4/21/08 7:28 AM, "Ralph H Castain" <rhc_at_[hidden]> wrote:

> I am finding that the memchecker code is again breaking the trunk,
> specifically on any machine that does not have valgrind installed.
> Apparently, memchecker now forces a requirement for valgrind?
> Here is what I get:
> --- MCA component memchecker:valgrind (m4 configuration macro)
> checking for MCA component memchecker:valgrind compile mode... static
> checking checking for the valgrind include directory ... none needed
> checking valgrind/valgrind.h usability... no
> checking valgrind/valgrind.h presence... no
> checking for valgrind/valgrind.h... no
> configure: WARNING: *** Could not find valgrind header files, as valgrind
> support was requested
> configure: error: *** Cannot continue
> Could somebody please fix this? I thought we had decided many moons ago that
> we would not require specific debuggers in default build configurations - I
> am somewhat surprised, therefore, to find that memchecker is "on" by
> default, and now requires valgrind!
> I have tried --disable-memchecker, but nothing will allow me to get past
> this error.
> Thanks
> Ralph
> _______________________________________________
> devel mailing list
> devel_at_[hidden]