Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

From: David Erukhimovich (daviderukh_at_[hidden])
Date: 2007-09-24 15:15:40

---------- Forwarded message ----------
Date: Mon, 24 Sep 2007 21:11:30 +0200
From: David Erukhimovich <daviderukh_at_[hidden]>
To: daviderukh_at_[hidden]
Subject: Re: [OMPI devel] Problem with adding new component

I'm Sorry, This time I'm sending the email to the right place.

I understand all of This.
The only thing I did this time is to download v1.2.3 from svn and build it
(without modifying anything!).
So I got The linkage error I attached last time. As you can see it isn't
connected with ORTE but with opmi_info or something


Tim Mattox wrote:

In the future, please continue to ask your questions on the developer
mailing list so that others can learn from them later via google, etc.

In this case, it appears the problem is that you originally copied the component
from the development trunk to modify for your own needs. The ORTE
layer has changed significantly between the 1.2 series and the trunk,
and thus your new code inherited the newer stuff that isn't compatible with
the 1.2 sources.

You should either make a copy of a component in the 1.2 series to
modify as you need, or, you should be building from a trunk checkout.

On 9/24/07, David Erukhimovich <daviderukh_at_[hidden]> wrote:

---------- Forwarded message ----------
Date: Mon, 24 Sep 2007 18:51:28 +0200 (IST)
From: David Erukhimovich <daviderukh_at_[hidden]>
To: David Erukhimovich <daviderukh_at_[hidden]>
Subject: Re: [OMPI devel] Problem with adding new component

   Hello Tom,
   Thanks for your responce.
   I tried to complies the ompi 1.2.3 (and 1.2.0) I downloaded from svn
     $ sh ; configure --prefix $MOSHOME/openmpi-install ; make all

   and I got the following compilation error:
     components.o: In function `ompi_info::open_components()':

   undefined reference to `orte_rml_base'
     ../../../ompi/.libs/ undefined reference to
     ../../../ompi/.libs/ undefined reference to
     ../../../ompi/.libs/ undefined reference to
     ../../../ompi/.libs/ undefined reference to
     ../../../ompi/.libs/ undefined reference to
     ../../../ompi/.libs/ undefined reference to
     collect2: ld returned 1 exit status

   What is the thing now?

   Thank you

On 9/23/07, Tim Mattox <timattox_at_[hidden] > wrote:

Hello David,
The development trunk (towards 1.3) is not binary compatible with
the 1.2 branch of Open MPI. Actually, AFAIK, no two versions of
Open MPI are guaranteed to be binary compatible.

You would need to compile and make your component from within
a 1.2 source tree. To be safe, you should use an svn check out that
matches the version you want to use, so in your case:
    svn co
and then go from there. There is a chance things will work from the
current 1.2 svn HEAD, but we do not test our code changes for
binary compatibility between versions.

On 9/23/07, David Erukhimovich <daviderukh_at_[hidden]> wrote:

I created a new component by modifying round_robin (on rmaps) a bit. I
compiled it using autogen. configure and make in the development (1.3)
version and it works fine.
Now I tried to copy the the new library I made (.so and .la files) to


lib folder of a stable release (1.2.3).
the release sees the new component but it doesn't work. the output

when I

run the following is:

   $ mpirun --mca rmaps mos_round_robin --mca rmaps_base_verbose 1


[mos204:04929] Scheduling policy: unspec
[mos204:04929] orte:base:open: querying component mos_round_robin
[mos204:04929] orte:base:open: component mos_round_robin does NOT want


be considered for selection
[mos204:04929] orte:rmaps:base:map: no components available!
[mos204:04929] [0,0,0] ORTE_ERROR_LOG: Not found in file
base/rmaps_base_map_job.c at line 201
[mos204:04929] *** Process received signal ***
[mos204:04929] Signal: Segmentation fault (11)
[mos204:04929] Signal code: Address not mapped (1)
[mos204:04929] Failing at address: 0xf7f1eb
[mos204:04929] [ 0] [0xffffe440]
[mos204:04929] [ 1] /lib/i686/cmov/


[mos204:04929] [ 2]
[mos204:04929] [ 3]

[mos204:04929] [ 4]


[mos204:04929] [ 5]
[mos204:04929] [ 6] mpirun(orterun+0x3d9) [0x804a1e9]
[mos204:04929] [ 7] mpirun(main+0x22) [0x8049e06]
[mos204:04929] [ 8] /lib/i686/cmov/
[mos204:04929] [ 9] mpirun [0x8049d81]
[mos204:04929] *** End of error message ***
Segmentation fault

So... what am I doing wrong and how can I fix it?

Thank you
devel mailing list

Tim Mattox, Ph.D. -
tmattox_at_[hidden] || timattox_at_[hidden]
     I'm a bright...
devel mailing list