Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

From: Alexander Margolin (alexam02_at_[hidden])
Date: 2007-08-16 16:49:25

This question seems so simple - and yet i ask:

I tried following all the steps in the manual:

1) svn co ompi
2) <changed some source code in ompi/mca/btl > *
3) ./ ; ./configure --prefix <some folder>
4) make all install

what do I get? The following compilation error:

make[2]: Leaving directory `somewhere/ompi/ompi/datatype'
Making all in debuggers
make[2]: Entering directory
/bin/sh ../../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I.
-I../../opal/include -I../../orte/include -I../../ompi/include
-I../../opal/mca/paffinity/linux/plpa/src/libplpa -I../.. -g -Wall
-Wundef -Wno-long-long -Wsign-compare -Wmissing-prototypes
-Wstrict-prototypes -Wcomment -pedantic
-Werror-implicit-function-declaration -finline-functions
-fno-strict-aliasing -pthread -g -MT libompitv_la-ompi_dll.lo -MD -MP -MF
.deps/libompitv_la-ompi_dll.Tpo -c -o libompitv_la-ompi_dll.lo `test -f
'ompi_dll.c' || echo './'`ompi_dll.c
mkdir .libs
 gcc -DHAVE_CONFIG_H -I. -I../../opal/include -I../../orte/include
-I../../ompi/include -I../../opal/mca/paffinity/linux/plpa/src/libplpa
-I../.. -g -Wall -Wundef -Wno-long-long -Wsign-compare
-Wmissing-prototypes -Wstrict-prototypes -Wcomment -pedantic
-Werror-implicit-function-declaration -finline-functions
-fno-strict-aliasing -pthread -g -MT libompitv_la-ompi_dll.lo -MD -MP -MF
.deps/libompitv_la-ompi_dll.Tpo -c ompi_dll.c -fPIC -DPIC -o
ompi_dll.c:102: error: initializer element is not constant
make[2]: *** [libompitv_la-ompi_dll.lo] Error 1
make[2]: Leaving directory `somewhere/ompi/ompi/debuggers'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/a/mosna/vol/vol0/aa/alexam02/ompi/ompi'
make: *** [all-recursive] Error 1

-Is there a problem with the specific checkout?
-How can i solve/work around the problem?
(tried removing deguggers directory - error in

* The i tried again without the modification and it still did the same error.