Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

From: Brian Barrett (bbarrett_at_[hidden])
Date: 2007-06-27 09:53:56

THe function name changes are pretty obvious (s/mca_pml_base/ompi/),
and I thought I'd try something new and actually document the
interface in the header file :). So we should be good on that front.


On Jun 27, 2007, at 6:38 AM, Terry D. Dontje wrote:

> I am ok with the following as long as we can have some sort of
> documenation describing what changed like which old functions
> are replaced with newer functions and any description of changed
> assumptions.
> --td
> Brian Barrett wrote:
>> On Jun 26, 2007, at 6:08 PM, Tim Prins wrote:
>>> Some time ago you were working on moving the modex out of the pml
>>> and cleaning
>>> it up a bit. Is this work still ongoing? The reason I ask is that
>>> I am
>>> currently working on integrating the RSL, and would rather build on
>>> the new
>>> code rather than the old...
>> Tim Prins brings up a point I keep meaning to ask the group about. A
>> long time ago in a galaxy far, far away (aka, last fall), Galen and I
>> started working on the BTL / PML redesign that morphed into some
>> smaller changes, including some interesting IB work. Anyway, I
>> rewrote large chunks of the modex, which did a couple of things:
>> * Moved the modex out of the pml base and into the general OMPI code
>> (renaming
>> the functions in the process)
>> * Fixed the hang if a btl doesn't publish contact information (we
>> wait until we
>> receive a key pushed into the modex at the end of MPI_INIT)
>> * Tried to reduce the number of required memory copies in the
>> interface
>> It's a fairly big change, in that all the BTLs have to be updated due
>> to the function name differences. It's fairly well tested, and would
>> be really nice for dealing with platforms where there are different
>> networks on different machines. If no one has any objections, I'll
>> probably do this next week...
>> Brian
>> _______________________________________________
>> devel mailing list
>> devel_at_[hidden]
> _______________________________________________
> devel mailing list
> devel_at_[hidden]