Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

From: Brian W. Barrett (bbarrett_at_[hidden])
Date: 2007-05-27 15:03:06

> On Sun, May 27, 2007 at 10:34:33AM -0600, Galen Shipman wrote:
>> Actually, we still need MCA_BTL_FLAGS_FAKE_RDMA , it can be used as
>> a hint for components such as one-sided.
> What is the purpose of the hint if it should be set for each interconnect.
> Just assume that it is set and behave accordingly. That what we decided
> to do in OB1. And the name is not very good too :) All RDMA networks
> behave like this.

Yeah, I agree -- the current semantics aren't very useful anymore. I'd
actually like to just redefine the FAKE_RDMA flag's meaning. Some of the
BTLs assume that there will be one set of prepare_src / prepare_dst calls
for each put/get call. This won't work for one-sided RDMA, were we'll
call prepare_dst at window creation time and reuse it. I'd like to have
FAKE_RDMA set for those BTLs.