Open MPI logo

Open MPI Development Mailing List Archives

  |   Home   |   Support   |   FAQ   |   all Development mailing list

From: Troy Benjegerdes (hozer_at_[hidden])
Date: 2005-10-21 18:26:32

On Fri, Oct 21, 2005 at 04:12:05PM -0500, Andrew Friedley wrote:
> I just committed a fix to the trunk to fix your original segfault down
> in opal_show_help() - this is the same problem Ken posted. This fix
> should make it into the v1.0 branch eventually. Even so, you are going
> to run into the real problem you were handling - this fix is just for
> proper error handling/output.
> The error below looks like a word size mismatch - one thing is compiled
> 64bit, the other is compiled 32bit. Make sure everything is compiled
> either 32bit or 64bit.

Another note.. I think I may have had some problems because I built with
'make -j16'.. has anyone else tried parallel make builds?

I have a working mpirun now.

Now I'm back to having NetPIPE segfault when I run it..

troy_at_opteron1:/usr/src/netpipe3-dev$ mpirun -np 2 -host
opteron1,opteron2 NPmpi
0: opteron1
1: opteron2
mpirun noticed that job rank 0 with PID 20293 on node "opteron1" exited
on signal 11.
1 additional process aborted (not shown)