It isn't in a file - unless you specify it, OMPI will set it automatically based on the number of procs on the node vs. what OMPI thinks are the number of available processors. The question is: why does OMPI not correctly know the number of processors on your machine?

I don't remember now, but did you send us this info:

  http://www.open-mpi.org/community/help/

If not, could you please do so? It would help us track down the problem.

Thanks
Ralph

On Apr 7, 2009, at 2:16 PM, Steve Kargl wrote:

On Tue, Apr 07, 2009 at 01:40:13PM -0600, Ralph Castain wrote:
I would really suggest looking at George's note first as I think you  
are chasing your tail here. It sounds like the most likely problem is  
that OMPI thinks you are oversubscribed and is setting sched_yield  
accordingly. which would fully account for these diffs.

Note that the methods for setting sched yield are different between  
the various releases, so something could be catching you here. If you  
are sure you aren't oversubscribing, then set -mca mpi_yield_when_idle  
0 on your cmd line to override any internal settings.


'-mca mpi_yield_when_idle 0' returns the performance of 1.3.1 to
that of 1.2.9.  In fact, 1.3.1 may be marginally better.  A comparison
can be see at

http://troutmask.apl.washington.edu/~kargl/ompi_cmp_yield.jpg

So, in what file is sched_yield set?

--
Steve
_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users