Amos,

The libraries that ldd isn't finding are intel fortran libraries. If you put that directory in your load library path things should work.

Doug Reeder
On Mar 16, 2009, at 12:05 PM, Amos Leffler wrote:

Hi Josh and Jeff,
     I found mpicc in /usr/local/lib (where I put it) and when I
tried the command "ldd mpicc" I got the following;
linux-f2f9:/usr/local/bin # ldd mpicc
       libopen-pal.so.0 => /usr/local/lib/libopen-pal.so.0 (0x00002afcd6bf6000)
       libm.so.6 => /lib64/libm.so.6 (0x00002afcd6e6c000)
       libdl.so.2 => /lib64/libdl.so.2 (0x00002afcd70c2000)
       libnsl.so.1 => /lib64/libnsl.so.1 (0x00002afcd72c7000)
       libutil.so.1 => /lib64/libutil.so.1 (0x00002afcd74de000)
       libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00002afcd76e1000)
       libpthread.so.0 => /lib64/libpthread.so.0 (0x00002afcd78f0000)
       libc.so.6 => /lib64/libc.so.6 (0x00002afcd7b0b000)
       /lib64/ld-linux-x86-64.so.2 (0x00002afcd69d8000)
       libimf.so => not found
       libsvml.so => not found
       libintlc.so.5 => not found
This is where the problem is.  Whenever I try to run the mpicc command
it tells me that it cannot find libimf.so.  Does that mean that there
is a problem in the compilation?
     Here is where I am stumped.
                                                                Amos

On Fri, Mar 13, 2009 at 1:25 PM, Jeff Squyres <jsquyres@cisco.com> wrote:
On Mar 13, 2009, at 2:42 PM, Amos Leffler wrote:

    Thanks for your advice.  I went back carefully through my PATH
file and corrected that so that I compiled openmpi-1.2.9 with the
Intel compilers seemingly without errors.  However, the simple test
examples wont run with the same error:
~/Desktop/openmpi-1.2.9/examples> mpicc hello_c.c
mpicc: error while loading shared libraries: libopen-pal.so.0: cannot
open shared object file: No such file or directory
I get similar results with the other examples.  Here is where I need help.


That's quite odd.

What does "ldd mpicc" show you?  (you may need to use the full path of
mpicc)


Amos Leffler

On Thu, Mar 12, 2009 at 12:22 PM, Joshua Bernstein
<jbernstein@penguincomputing.com> wrote:
Hi Amos,

      It looks like you do not have permission to make the directory
/usr/local/etc. Either you need to run the make all install as root, so
you
have permission to that directory, or you need to use the
--prefix=<path>
option to configure so that the installation gets installed into a path
where you have permission.

-Joshua Bernstein
Senior Software Engineer
Penguin Computing

On Mar 12, 2009, at 12:13 PM, Amos Leffler wrote:

Hello Forum,
        Attached is a file of my installation and trying examples
for openmpi-1.2.9 which were not successful. Hopefully the problem is
a simple one and obvious to a more experienced user.

  I am trying to install and test openmpi-1.2.9. I found that I
could not use the Intel 11.0/.081 C++
and Fortran compilers although I think the problem is with these
compilers not openmpi.  The openmpi-
1.2.9 did compile successfully with the internal compilers of SuSE
10.2.  However, at the end of the
"make all install" command output I noted that some of the make
commands did not run  properly as
shown below.
  I tried to run some of the simple examples and was not successful.
For hello_c.c I received the
message "mpicc not found".  Is there a simple workaround?

make[3]: Leaving directory
`/home/amos/Desktop/openmpi-1.2.9/opal/libltdl'
make[2]: Leaving directory
`/home/amos/Desktop/openmpi-1.2.9/opal/libltdl'
Making install in asm
make[2]: Entering directory `/home/amos/Desktop/openmpi-1.2.9/opal/asm'
make[3]: Entering directory `/home/amos/Desktop/openmpi-1.2.9/opal/asm'
make[3]: Nothing to be done for `install-exec-am'.
make[3]: Nothing to be done for `install-data-am'.
make[3]: Leaving directory `/home/amos/Desktop/openmpi-1.2.9/opal/asm'
make[2]: Leaving directory `/home/amos/Desktop/openmpi-1.2.9/opal/asm'
Making install in etc
make[2]: Entering directory `/home/amos/Desktop/openmpi-1.2.9/opal/etc'
make[3]: Entering directory `/home/amos/Desktop/openmpi-1.2.9/opal/etc'
test -z "/usr/local/etc" || /bin/mkdir -p "/usr/local/etc"
/bin/mkdir: cannot create directory `/usr/local/etc': Permission denied
make[3]: *** [install-sysconfDATA] Error 1
make[3]: Leaving directory `/home/amos/Desktop/openmpi-1.2.9/opal/etc'
make[2]: *** [install-am] Error 2
make[2]: Leaving directory `/home/amos/Desktop/openmpi-1.2.9/opal/etc'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/home/amos/Desktop/openmpi-1.2.9/opal'
make: *** [install-recursive] Error 1

  Any help would be appreciated.
                                                     Amos
Leffler<install.output>_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users

_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users

_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users


--
Jeff Squyres
Cisco Systems

_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users

_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users