First, you can add --launch-agent rsh to the command line and that will have OMPI use rsh.

It sounds like your remote nodes may not be seeing your OMPI install directory. Several ways you can resolve that - here are a couple:

1. add the install directory to your LD_LIBRARY_PATH in your .cshrc (or whatever shell rc you are using) - be sure this is being executed on the remote nodes

2. add --prefix=path-to-install on your cmd line - this will direct your remote procs to the proper libraries

Ralph


On Mar 5, 2009, at 10:18 AM, justin oppenheim wrote:

Maybe I should also add that the program
my_mpi_executable is locally installed under the same root directory as that under which  openmpi-1.3 is installed. This root directory is NSF mounted on the working nodes.

Thanks,
JO

--- On Thu, 3/5/09, justin oppenheim <jl09981@yahoo.com> wrote:
From: justin oppenheim <jl09981@yahoo.com>
Subject: Re: [OMPI users] Run-time problem
To: "Ralph Castain" <rhc@lanl.gov>
Date: Thursday, March 5, 2009, 12:04 PM

Hi Ralph:

Thanks for your prompt response. I am using openmpi-1.3, Suse 10.3. I installed openmpi-1.3 with the option

./configure --prefix=/where/to/install

and then just

make all install

I thought the default connection mode is rsh, but I had to invoke ssh-agent, in order not have to enter password one by one. How to change to rsh?

Thanks,
JO

--- On Thu, 3/5/09, Ralph Castain <rhc@lanl.gov> wrote:
From: Ralph Castain <rhc@lanl.gov>
Subject: Re: [OMPI users] Run-time problem
To: jl09981@yahoo.com, "Open MPI Users" <users@open-mpi.org>
Date: Thursday, March 5, 2009, 11:40 AM

Could you tell us what version of Open MPI you are using, a little about your system (I would assume you are using ssh?), and how this was configured?

Thanks
Ralph


On Mar 5, 2009, at 9:31 AM, justin oppenheim wrote:

Hi:

When I execute something like

mpirun -machinefile machinefile my_mpi_executable

I get something like this

my_mpi_executable symbol lookup error: remote_openmpi/lib/libmpi_cxx.so.0: undefined symbol: ompi_registered_datareps

where both my_mpi_executable and remote_openmpi are installed on NSF mounted locations.

Any clue?

thanks

JO

_______________________________________________
users mailing list
users@open-mpi.org
http://www.open-mpi.org/mailman/listinfo.cgi/users